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TerraSonde reserves the right to make changes in specifications and other information contained in this

publication without prior notice, and the reader should in all cases consult TerraSonde to determine

whether any such changes have been made. This manual may not be reproduced, and is intended for the

exclusive use of TerraSonde customers.

The terms and conditions governing the sale and use of the TerraLink software program consist solely of

those set forth in the written contracts between TerraSonde and its customers. No statement contained in

this publication, including statements regarding capacity, suitability for use, or performance of products,

shall be considered a warranty by TerraSonde for any purpose or give rise to any liability of TerraSonde.

In no event will TerraSonde be liable for any incidental, indirect, special, or consequential damages

(including lost profits) arising out of or relating to this publication or the information contained in it, even

TerraSonde has been advised, knew, or should have known of the possibility of such damages.

The TerraLink program described in this document is copyrighted and is confidential information and a

proprietary product of TerraSonde. The copyright laws prohibit the copying of this manual or any of the

support software programs without the written consent of TerraSonde, except in the normal use of the

product, or to make a backup copy. This exception does not allow a copy to be made for others. Copying,

under the law, includes translating into another language or format.

(c) Copyright 2002-2003    All Rights Reserved

TerraSonde

2434 30th Street

Boulder, CO  80301

USA

(303) 545-5848      FAX (303) 545-6066

www.terrasonde.com

All rights reserved.
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General Notice: some of the product names used herein have been used for identification purposes only

and may be trademarks of their respective companies.

The Audio Toolbox is a trademark of TerraSonde.
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Quick Start

No time for manuals? Read this section to jump-start TerraLink!

ÿ Install the software:  If installing from a CD, insert the TerraLink CD into your CD-
Rom.  Double-click the CD icon.  In the window that opens, double-click the file
‘TerraLink Setup.exe’ and follow the onscreen instructions.  If installing from a
downloaded or emailed .exe file, copy the file to your desktop, double-click it, and follow
the instructions.

ÿ Connect the Toolbox:  Plug the Toolbox computer interface cable into the MIDI In and
Out ports on the Toolbox, and the opposite end into the computer’s serial port.  If your
computer does not have a serial port, a USB-serial interface device is required.  We
recommend Belkin single-port USB-serial adapters.  Most RS232 ports should work,
although you may have to experiment to find one that is available.  From the TerraLink
Edit menu, select Preferences to choose from the available COM ports.

ÿ Run TerraLink:  From the Start menu, select Program Files> TerraLink 1.2> TerraLink
ÿ Enter the Registration code:   A registration code is required to fully use TerraLink.

From the Edit menu, select Registration Codes.  In the dialog box that appears, select
New, enter your registration code, and select OK.  If you do not have a registration
code, you will be able to run the program as a viewer.  To purchase a registration code,
contact TerraSonde at 888-433-2821.

ÿ Explore:  Open a new project, put the Toolbox in Computer Interface mode,  and
upload the memories from the Toolbox.  Or, if you don’t have a registration code, just
open the example file.  For the Real Time Interface, just click the Rti button on the
Toolbar after selecting a port.  The Toolbox will need to be in the RTA, FFT, or Energy-
Time Graph function to view the results in real time.

ÿ Want more?  Well, read on. You will learn how to cut and paste project files, save
multiple project files, store them back into the Toolbox, do advanced graphing and math
tricks, and print graphs.
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Setup

Computer Requirements
An IBM compatible PC running Windows 98, 2000, Me or XP is required.  Also, an available
serial port or USB-serial adapter is needed for communication with an Audio Toolbox.

Registration Codes
TerraLink uses Registration Codes as a means of licensing the software.  Without a
Registration Code, you will be able to open Project Files, examine graphs, and print.
However, you will not be able to create or save Project Files, or communicate with a Toolbox
(upload/download memories or use the Real Time Interface).  You can send the TerraLink
program to a client with your Project File so that the client can view and print data without
the need for a Registration Code.

Also, the functions that interact with a Toolbox will only work if a Registration Code was
purchased for that Toolbox.  Separate Registration Codes are required for every Toolbox that
you wish to work with.

You can purchase as many Registration Codes as you wish, if you need to work with more
than one Toolbox.  You can install TerraLink on as many computers as you like, and as long
as you have the correct Registration Codes it will communicate with the connected Toolbox.

From the Edit menu, select Registration Codes.  In the dialog box that appears, select New,
enter your registration code, and select OK.

Preferences
TerraLink stores a set of preferences on your computer.
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Personal Information

Select the Preferences function on the Edit Menu to enter information about your company
and the project that will be printed on each graph.

You can enter Name, Company, Address, Telephone, Email, and Graph Title information.

Serial Connection

The serial connection needs to be set before using TerraLink.  In the Preferences box, you
can select the appropriate COM port.  If you do not set it, you will be prompted to set it.
This setting will be stored so that you do not need to re-enter it the next time you run the
program.
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Overview

TerraLink operates in two distinct, but integrated, environments:  the Project File and the
Real Time Interface (RTI.)  The RTI is simply an extension of the Toolbox screen for the
supported functions.  The Project File is where most of TerraLink’s operations take place.
Graphs that are created in the RTI can be saved as a memory in a Project File and later
manipulated just like a memory that originated in the Toolbox.

TerraLink provides Standard tools for handling Project Files and some Global settings and
tools for manipulating all graph types.  Other tools may be available to individual graph types
and are described in the Graph Window section of the manual.

Standard Tools

New Tool

Clicking on the New tool opens a new Project File.  This can also be accomplished by
selecting File> New on the Menu bar.

Open Tool

Clicking on the Open tool opens a saved Project File.  This can also be accomplished by
selecting File> Open on the Menu bar.  In the Open dialog box that appears, select a
previously saved Project File and click OK.

Save Tool

Clicking on the Save tool saves the currently selected Project File.  This can also be
accomplished by selecting File> Save on the Menu bar.  Project Files are saved with a ‘.tlk’
file extension.

Print Tool

Clicking on the Print tool prints the graph of the currently selected Project File.  This can also
be accomplished by selecting File> Print on the Menu bar.  Any information entered in the
Preferences box will appear below the graph on the printed page.
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Global Graph Tools
The following tools are available to all graphs:

Drag Up & Down Tool

This tool allows you to vertically center a graph by dragging its’ position up or down. Left-
click and hold to drag.  This does not alter any values of the graph and is simply a display
tool.

Readout Cursor Tool

The Readout Cursor tool allows you to select points on the graph and display the actual
values of those points.

Global Graph Settings
The following settings are available to all graphs:

Colors

To change the color of a specific graph, right-click inside the Graph window and select Colors
from the drop-down menu (or from the Menu bar, select Graph> Colors).  In the Colors box,
select the memory you wish to adjust from the mem combo box.  Then adjust the color
using the color sliders.  You can adjust the color of each memory on the graph as desired,
then click Done.
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Scale Resize

To resize the Graph window’s y-axis scale, right-click anywhere inside the Graph window and
select Scale.  In the Resize box, set the desired Min dB and Max dB values and click Done.
This will re-scale the vertical axis to your settings.

Grid Combo Box

You can also adjust the grid to show lines every 10 dB, 5 dB, or 1 dB.  To do this, select the
desired grid from the Grid combo box.  The default is 10 dB.
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Project Files

The main operating environment of TerraLink is the Project File.  A Project File can hold 40
memories (just like a Toolbox.)  Usually, you will start a new Project File, load the memories
from a Toolbox, and go from there.  You can save the file to your hard disk, email it to
someone else, and store it back into your Toolbox or a different Toolbox.

Project Files utilize a Graph window and the Project Data box.  Each open Project File has its
own Graph window, so there can be several Project File Graph windows on the screen at
once, while the Project Data box is global and displays only the 40 memories of the currently
selected Project File.

The Project Data Box
The Project Data box is where you modify the Project File’s contents.

Importing Memories

The first thing you will probably want to do is to get the memories from the Toolbox into
TerraLink.  To do this, put the Audio Toolbox into Computer Interface mode.  In TerraLink,
create a new Project File (File> New), and click the Import button in the Project Data box
to transfer the Toolbox memories to the computer.

Once the Toolbox memories are imported, you can rename, re-order, and delete individual
memories.  To make it easier to work with multiple Project Files, there is only one Project
Data box displayed at a time for the selected Project File. The name of the currently selected
Project File is displayed at the top of the Data Table in the Project Data box and its’ Graph
window will be highlighted. There are as many Graph windows displayed as there are Project
Files open and these can be minimized to free up valuable desktop space.  To select another
Project File, click anywhere inside that Project’s Graph window and the Project Data box will
display all 40 memories of that Project.
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Copying Memories

To copy memories from one Project File to another, just open both Project Files (to get two
Graph windows), and select the Project containing the memory you wish to copy.  On the
Data Table in the Project Data box, right-click the cell of the memory.  From the drop-down
menu that appears, select Copy, then select the Graph window of the Project File that you
wish to copy the memory to.  Now right-click on any unused cell in the Project Data box to
open the drop-down menu, and select Paste.  Note that it is possible to overwrite a memory
by pasting a new memory into its’ cell.

Moving Memories

To move memories from one Project File to another, just open both Project Files (to get two
Graph windows), and select the Project containing the memory you wish to move.  On the
Data Table in the Project Data box, right-click the cell of the memory.  From the drop-down
menu that appears, select Cut, then select the Graph window of the Project File that you
wish to move the memory to.  Now right-click on any unused cell in the Project Data box to
open the drop-down menu, and select Paste.  Note that it is possible to overwrite a memory
by pasting a new memory into its’ cell.

Composite Project Files

You can open several Project Files at once, and cut, copy and paste memories from one to
another, creating a Project File that is a composite of memories created at different times,
even from different Toolboxes.

In some cases you can sum several graphs of the same type and store the results back into
the Project File as a new memory.  This memory can then be used as the basis for a
difference mode display.

Exporting Memories

The memories from any Project File can be transferred to a Toolbox by using the Export
button in the Project Data box.

Project Data Box Button

This button can be used to open the Project Data Box when at least one Project File is open.

The Graph Window
The Graph window is where all memory data is displayed.  To access the various graph
types, use the following tools:

Graph Combo Box

This menu allows you to select the type of graph to display in the Graph window.  Click on
the drop-down arrow and select the type of graph you wish to work with.  That type will now
be displayed in the Graph combo box.
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Memory Menu

Once you have selected the type of graph you wish to work with in the Graph combo box,
click on the M button to open the Memory Menu and choose from the available memories of
that graph type.  Clicking on a memory name will display it in the Graph window and place a
check next to the memory name, indicating that it has been selected.  For all graph types
except ETG and SSG, you can select and display as many memories as are available in the
Project File.
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Real Time Analyzer (RTA)

You can display as many RTA graphs as you like on the screen.  Each will show up in a new
color.  RTA memories are displayed and remain in the original frequency band resolution
(octave or 1/3-octave) they were created in.  RTA memories of different resolutions can be
displayed in the Graph window simultaneously.

Average Tool

Select the Average Tool to algebraically average all of the graphs currently being displayed.
[Note that this is a true algebraic average.  For example, 60 dB and 80 dB do NOT average
to 70 dB.]  The resulting average curve may be stored as a new memory by using the Copy
function.

Difference Tool

Select the Difference Tool to see how one or more graphs compare to a reference graph.
The reference (baseline) graph is selected from the drop-down menu by right-clicking inside
the Graph window.  [In this case, the difference is in dB.  So, for example, 70 dB minus 60
dB is 10 dB.]
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FFT Analyzer (FFT)

You can display as many FFT graphs as you like in the Graph window.  Each will show up in
a new color.

[INSERT SPLINE PIC]

On the Menu bar, select Graph> FFT.  Here you can select between 7 different graph
formats for viewing the FFT data.  These include the normal octave, 1/3-octave, 1/6-octave,
and 1/12-octave bars that are the same as the bars seen on the Toolbox screen.  You can
also view the data as octave, 1/3-octave, and 1/12-octave graphs that have been curve-fit
and smoothed.  The curve-fit algorithm used is a spline, with as many output points as are
on the fully zoomed-out screen.

The bars are created using algebraic summing (as on the Toolbox).  As you consolidate the
data more, the level of the bars will rise.  For example, if you were measuring wide-band
pink noise, as you switch from 1/12-octave to 1/6-octave to 1/3-octave to octave-band
resolution, the level of the bars will rise.  In contrast, the curve graphs that are drawn
always use the 1/12-octave data, so they do not rise as the smoothing is increased.

Average Tool

Select the Average Tool to algebraically average all of the graphs currently being displayed.
[Note that this is a true algebraic average.  For example, 60 dB and 80 dB do NOT average
to 70 dB.]  The resulting average curve may be stored as a new memory by using the Copy
function.

Difference Tool

Select the Difference Tool to see how one or more graphs compare to a reference graph.
The reference (baseline) graph is selected from the drop-down menu by right-clicking inside
the Graph window.  [In this case, the difference is in dB.  So, for example, 70 dB minus 60
dB is 10 dB.]
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Sound Study Graph

Only one Sound Study Graph can be viewed at a time.  If a particular point in time
overloaded the Toolbox, the Overload indicator will be shown as the cursor moves across the
screen.

There are no special tools that are used with the Sound Study Graph.
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Energy Time Graph

Only one ETG can be viewed at a time.  There is one special tool available.

RT60 Tool

If you select the RT60 Tool, you can set the 2 endpoints of a line that represents a slope on
the ETG.  This slope is translated to an equivalent RT60 time, which is displayed in the upper
right corner of the Graph window.

The x-axis of the Energy-Time Graph can be viewed in milliseconds (ms), feet (ft), or meters
(m).  To adjust this setting, click Graph on the Menu bar, scroll down to ETG and select one
of the three options.  The default is ms.
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Amplitude Sweep

You can view multiple Amplitude graphs at the same time on the screen.  Amplitude
memories are displayed and remain in the original frequency band resolution (1/3-octave or
1/12-octave) they were created in.

Average Tool

Select the Average Tool to algebraically average all of the graphs currently being displayed.
[Note that this is a true algebraic average.  For example, 60 dB and 80 dB do NOT average
to 70 dB.]  The resulting average curve may be stored as a new memory by using the Copy
function.

Difference Tool

Select the Difference Tool to see how one or more graphs compare to a reference graph.
The reference (baseline) graph is selected from the drop-down menu by right-clicking inside
the Graph window.  [In this case, the difference is in dB.  So, for example, 70 dB minus 60
dB is 10 dB.]
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Impedance Sweep

You can view multiple Impedance Sweep graphs at the same time on the screen.
Impedance memories are displayed and remain in the original frequency band resolution
(1/3-octave or 1/12-octave) they were created in.

The Grid combo box has no effect on the Impedance graphs and the Scale Resize box has
different settings than those for all other graph types.  Here you can select a number of
different y-axis settings from 0-20 Ohms to 0-8000 Ohms.

Average Tool

Select the Average Tool to algebraically average all of the graphs currently being displayed.
[Note that this is a true algebraic average.  For example, 60 dB and 80 dB do NOT average
to 70 dB.]  The resulting average curve may be stored as a new memory by using the Copy
function.

Difference Tool

Select the Difference Tool to see how one or more graphs compare to a reference graph.
The reference (baseline) graph is selected from the drop-down menu by right-clicking inside
the Graph window.  [In this case, the difference is in dB.  So, for example, 70 dB minus 60
dB is 10 dB.]
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Real Time Interface

TerraLink provides a Real Time Interface that displays the RTA, FFT, and Energy-Time
graphs on the computer screen as the function is running on the Toolbox.

Real Time Interface Controls

The Real Time Interface is used to display result sfomr the Toolbox on the PC screen.

Use these buttons to operate the Real Time Interface:

Rti Button

With the Toolbox powered on and connected to the computer, open the Real Time Interface
window by clicking on the Rti button in the center of the Toolbar.

Play Button

With the RTA, FFT, or ETG running on the Toolbox, click the Play button.

You should now see the computer graph dynamically displaying the graphical data from the
Toolbox.  The Real Time Interface screen and the Toolbox screen are updated
simultaneously.

Pause Button

To freeze the display, click the Pause button.

You can use the Copy function at any time (paused or running) to store the current memory
data on the clipboard.  Then you can switch to any open Project File’s Project Data box and
use the Paste function to paste the current memory into one of the 40 available cells of that
Project File.


